Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Midi from one device to another

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos
View previous topic :: View next topic  
Author Message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Sat Aug 31, 2019 12:22 pm    Post subject: Midi from one device to another Reply with quote

As a newbie I get to ask really basic questions. I think thats the unwritten rule. Anyway, I created a song using midi on my Yamaha MOFX08 and used Logic to convert all my midi files to audio so I could have a finished audio file. Great ... done... Now I have my new whizbang Korg Kronos (which I totally love) and when I load the file into Logic and play I see the volume meters responding on the midi channels but no sound. I put them on solo still no sound. What am I doing wrong? Isn't a midi track transferable to different hardware? When I loaded the song into Logic Pro initially it told me that the MOFX08 device wasn't available which made sense but I thought it would play. Is it a channel thing? Something in my preference settings or Logic or the Kronos? Any help would be greatly appreciated....
Back to top
View user's profile Send private message
SKung
Full Member


Joined: 20 Aug 2011
Posts: 147

PostPosted: Sat Aug 31, 2019 1:31 pm    Post subject: Reply with quote

I don't really understand your final configuration with the kronos.

You started making a midi file with the MOX as an audio generator and recorded that to an audio file. Understood.

Then you connected the kronos and you write you loaded "the file" into logic.

Assuming it was the midi file you made with the MOX and you just exchanged it with the kronos there could be different reasons for that:

1.
Your computer or the logic software detects that a different midi device is connected than before: In this case it could assign a new midi port but the midi file you created sill contains the old midi port and logic sends all midi signals to there

2.
You use program change commands in your midi file to adress certain sounds in the MOX. The kronos uses different adresses than the MOX.

3.
What about the midi configuration in the kronos? Is is configured properly and receives any signal at all?
What does the kronos midi driver on your computer say? Does the kronos appear there?

Edit: I suggest you start with a blank new file and try to get an audio output from the kronos via midi
Back to top
View user's profile Send private message
rpowell01
Full Member


Joined: 03 Feb 2011
Posts: 201

PostPosted: Sat Aug 31, 2019 1:48 pm    Post subject: Re: Midi from one device to another Reply with quote

whelafam wrote:
As a newbie I get to ask really basic questions. I think thats the unwritten rule. Anyway, I created a song using midi on my Yamaha MOFX08 and used Logic to convert all my midi files to audio so I could have a finished audio file. Great ... done... Now I have my new whizbang Korg Kronos (which I totally love) and when I load the file into Logic and play I see the volume meters responding on the midi channels but no sound. I put them on solo still no sound. What am I doing wrong? Isn't a midi track transferable to different hardware? When I loaded the song into Logic Pro initially it told me that the MOFX08 device wasn't available which made sense but I thought it would play. Is it a channel thing? Something in my preference settings or Logic or the Kronos? Any help would be greatly appreciated....


Do as whelafam stated plus in Logic you can save your project to raw midi and load that file into the Kronos. Remember the Kronos has a hard drive so it has storage and can load midi files into the sequencer of the Kronos..
Back to top
View user's profile Send private message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Sat Aug 31, 2019 4:46 pm    Post subject: Midi from one device to another Reply with quote

Is there a checklist available to ensure that I have setup the midi correctly? I have installed the driver and set my audio preferences to Korg Kronos. Is there anything else I need to do to get started?

If I have screwed something up, is there a way to reset everything and start over?
Back to top
View user's profile Send private message
SKung
Full Member


Joined: 20 Aug 2011
Posts: 147

PostPosted: Sat Aug 31, 2019 6:45 pm    Post subject: Reply with quote

Start at system-level.

Close Logic and open the Kronos driver software. Does your Kronos appear in the list?
Open Logic, there must be a configuration for MIDI devices (check manual if you don't find it), is the Kronos listed as a MIDI device?
Start a new song, create a MIDI track with Kronos as MIDI device, enter some notes, play the song. Does the Kronos play these notes?

If these tests are OK, then the problem is within the MIDI file. Since I don't know that file and its parameters I can't tell what it is.

I suspect that there are program changes within the file and the sound adresses between MOX and Kronos are different.
Back to top
View user's profile Send private message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Sat Aug 31, 2019 11:32 pm    Post subject: Reply with quote

Thanks I will give these items a try... I appreciate the feedback... I'll let you know how I make out.
Back to top
View user's profile Send private message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Sun Sep 01, 2019 12:46 am    Post subject: Reply with quote

Okay, so this is the result. I have a Kronos listed in my Audio Midi Setup on my iMac. I am using the USB connection and the Audio plays and records fine. It actually indicates that I have 2 in and 2 out. As far as midi goes.....I got a message when I started logic "error initializing core midi" - Warning - Midi Services not available. I tried to record a midi track but no luck.
Back to top
View user's profile Send private message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Sun Sep 01, 2019 1:22 am    Post subject: Reply with quote

Latest.... I went to the Korg site downloaded the driver and installed it. The previous was installed using the CD that came with my keyboard. Then I rebooted and restarted Logic Pro which was able to record and playback midi. I don't know what fixed it but I'm glad it did. Now I can go back and see why midi files created using my MOFX8 aren't playing. At this point if I can't figure it out then I will be happy with the fact that midi is available for me now. Thanks for the support.... I'm sure I will have more fun challenges ahead....
Back to top
View user's profile Send private message
whelafam



Joined: 27 Aug 2019
Posts: 13

PostPosted: Tue Sep 03, 2019 3:03 pm    Post subject: Saga continues Reply with quote

Well I thought I was out of the woods with my midi issues but I got the "Error initializing core midi" again. I googled it and found out it was a common problem for people since Mojave so it wasn't a newbie issue. Ultimately based on prior user posts I began clearing out all midi drivers and reseting all preferences other than key commands in logic. At least I knew at this point everything was clean. Then I started Logic and didn't have the issue on the first try but I did subsequently. It appears that it is a timeout issue so again following info posted in Apple forums I now load the Audio Midi Setup before starting Logic X and it appears that it solves the problem.....Anyone else experience this issue and was this how you solved it?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group